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Introduction 

In this chapter we’ll talk about the virtual machine technology that is used by Parallels® 
Desktop and will familiarize you with the main characteristics of a virtual machine created by 
Parallels Desktop. 

In This Chapter 
Key Terms and Technologies................................................................................................ 5
Supported Guest Operating Systems..................................................................................... 7
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Key Terms and Technologies 
In hopes of making your experience as effortless as possible, we’ve designed Parallels Desktop to 
be extremely user-friendly, even if you’re a computer “newbie.” This section highlights some of the 
terms you’ll need to know as you work your way through this guide.  

Virtual machine (VM): The whole point of Parallels Desktop is simulating other computers 
running inside your Mac. This computer-within-your Mac has its own operating system, its own 
software suite, and its own “screen.”  

You might call it a PC simulator, an imitation PC, or a mock computer. But in the computer-
science industry, it has a standard name: a virtual machine. Every time you start up Parallels 
Desktop for Mac, you’re actually turning on a virtual machine running Windows or any other 
operating system you want to use. 

Each virtual machine behaves as though it’s a PC with the following components: 

 an Intel Pentium processor; 
 a generic motherboard compatible with Intel i815 chipset; 
 up to 1500 MB of memory; 
 monitor with VESA 3.0 support. After a new virtual machine is just created, its monitor 

resolution will be either 640x480 or 1024x768 (VGA and SVGA). Later you will have the 
opportunity to either install Parallels Tools with a video driver in Windows, or set your own 
screen resolution; 

 a floppy drive (mapped to an image file); 
 up to four IDE disk drives. These can be either virtual hard drives (from 20 MB up to 128 

GB each, in the form of hard drive image files) or CD/DVD-ROM drives (mapped to either 
actual drives or image files); 

 Ethernet network card compatible with RTL8029. Parallels Desktop supports bridging to 
wireless networking adapters; 

 up to four serial (COM) ports (each mapped to a socket or to an output file); 
 up to three bi-directional parallel (LPT) ports (mapped to output files); 
 a standard PC keyboard; 
 a PS/2 scroll-wheel mouse. 

A virtual machine lets you do tricks like these: 

 Simultaneously run multiple operating systems (OSes) and their programs on a single 
computer. 

 Create numerous virtual machines, each with a full set of standard virtual hardware. 
Operating systems and applications are isolated inside these virtual machines and share 
physical hardware components with the real computer. 

 Switch between operating systems without having to restart the Mac. 
 Simplify your environment, combining all you need on one machine. The result: reduced 

hardware costs, lower operating expenses, and increased productivity. 

Primary Operating System (Primary OS): This is the operating system that loads when you hit the 
power button on your computer. In your case, it’s Mac OS X. 
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Guest Operating System (Guest OS): This is the reason you bought Parallels Desktop: it’s a 
second, different operating system that you can run simultaneously with the primary OS. The 
guest OS on your Mac might be Windows XP, or Linux, or any of many other operating 
systems—and they all can be running simultaneously in different windows!

Hard Disk Image: Just as a virtual machine is a simulated PC, a hard disk image is a simulated 
hard drive. It’s actually just a file (of a size you can specify) on your real hard disk, but it looks to 
the virtual machine like its own actual drive. 

ISO Image: A file that contains the entire contents of a CD-ROM disc or DVD, commonly used 
to install a guest operating system in a VM.  

FDD Image: A file that contains the contents of a floppy disk, used to install specific guest 
operating systems, such as OS/2. 
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Supported Guest Operating 
Systems 

The current version of Parallels Desktop officially supports the following guest operating 
systems: 

Microsoft Windows Guest Operating Systems: 
 Windows Vista 
 Windows Server 2003 Standard Edition SP0 
 Windows Server 2003 Standard Edition SP1 
 Windows Server 2003 Enterprise Edition SP0 
 Windows Server 2003 Enterprise Edition SP1 
 Windows Server 2003 Web Edition SP0 
 Windows Server 2003 Web Edition SP1 
 Windows XP SP2 Professional 
 Windows XP SP2 Home 
 Windows XP SP1 Professional 
 Windows XP SP1 Home 
 Windows XP SP0 Professional 
 Windows XP SP0 Home 
 Windows 2000 Professional Edition SP4 
 Windows 2000 Server SP4 
 Windows 2000 Advanced Server SP4 
 Windows NT Workstation 4.0 SP6 
 Windows NT Server 4.0 SP6 
 Windows ME 
 Windows 98 
 Windows 95 
 Windows 3.11 
 Windows 3.1 

Linux Guest Operating Systems: 
 Red Hat Enterprise Linux WS4 
 Red Hat Enterprise Linux AS4 
 Red Hat Enterprise Linux WS3 
 Red Hat Enterprise Linux ES4 
 Red Hat Enterprise Linux ES3 
 Red Hat Linux 9 
 Red Hat Linux 8 
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 Red Hat Linux 7.3 
 Debian Linux 3.1 
 Fedora Core Linux 4 
 Fedora Core Linux 3 
 SUSE Linux 10 
 SUSE Linux 9.3 
 SUSE Linux 9.2 
 SUSE Linux 9.1 
 SUSE Linux 9.0 
 Mandriva Linux 10.1 
 Mandriva Linux 10 
 Mandriva Linux 9.2 

FreeBSD Guest Operating Systems: 
 FreeBSD 5.4 
 FreeBSD 5.3 
 FreeBSD 4.5 
 FreeBSD 4.1 

OS/2 and eComStation Guest Operating Systems: 
 OS/2 Warp 4.5  
 OS/2 Warp 4 
 OS/2 Warp 3 
 eComStation 1.2 
 eComStation 1.1 

Sun Solaris Guest Operating Systems: 
 Solaris 10 
 Solaris 9 

MS-DOS Guest Operating Systems: 
 MS-DOS 6.22 
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Installing Parallels Desktop 

In this chapter you’ll learn how to install Parallels Desktop on your Mac. 

 

In This Chapter 
System Requirements............................................................................................................ 9
Installing Parallels Desktop................................................................................................... 9
 
 

System Requirements 
Parallels Desktop requires a Mac that contains an Intel processor, such as a 2006-model iMac, 
Mac Mini, MacBook Pro, or Mac Pro. It does not work on older Mac models.  

Your Mac should be running Mac OS X 10.4.6 or higher. The newest version Mac OS X 10.5 
(Leopard) is supported experimentally. 

To check your version of Mac OS X, go to the Apple menu in the menu bar, and choose About 
This Mac. 
 

Installing Parallels Desktop 
Now that you’re past the geek-speak, you’re ready to install Parallels Desktop! 

To install Parallels Desktop: 

1 First, download the Parallels Desktop installation file from Parallels site. 

 To download a trial version, visit the Parallels Download Center 
http://www.parallels.com/en/download. 

 To buy the full commercial version, visit the Parallels Buy Online page 
http://www.parallels.com/en/buyonline. 

Select the Parallels Mac OS X package for downloading. 

2 When software downloading is complete, double-click the Parallels-Desktop-
XXXX-Mac.dmg file on your desktop. In the Parallels Desktop window, double-click the 
Parallels-Desktop.pkg icon to start installing. 

 

http://www.parallels.com/en/download
http://www.parallels.com/en/buyonline
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3 On the Introduction screen, click Continue, shown here. 

 
4 On the Software License Agreement screen, use the scroll bar to read the entire agreement. 

Then click Continue. 
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In the pop-up dialog box, click Agree to continue installing.  

 
5 Next you’ll see the Select a Destination screen. Specify which hard drive you want to use as 

Parallels Desktop’s home and then click Continue. Currently, you can install Parallels 
Desktop only on the same drive with Mac OS X. Parallels Desktop installation takes only 
40.5MB. Later, you may prefer to store virtual machines that take much more disk space in 
a different drive (if, in fact, you have more than one drive). To learn how to change folder 
for storing virtual machine, refer to the Managing Virtual Machines->Setting Parallels Desktop 
Preferences->Common topic in User Guide. 

 
6 Finally, click Install to start the Parallels Desktop installation. 
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Note: Of course, you can return to the previous steps by clicking the Go Back button at any 
time. 

 
7 When Parallels Desktop installation is complete, you see this dialog box. Click Close. 

You’re ready to enter the Parallels dimension! 
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Starting Parallels Desktop 

To start Parallels Desktop: 

 In the Finder, open your Applications folder, and then double-click on the orange Parallels 

icon  . 

To save yourself from having to burrow into Applications every time you want to run the 
program, consider dragging its icon onto your Dock. 
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Activating Parallels Desktop 

You need to get an activation key and activate your copy of Parallels Desktop with it to be able 
to run and use virtual machines. 

Getting an Activation Key 

If you already have an activation key, skip this section and proceed to Activating Your Copy of 
Parallels Desktop below in this topic.  

To get a free trial activation key: 

1 Click Help in the menu and select Activate Product. This opens the Activate Product screen. 

2 In the Activate Product screen, click the “obtain a free trial activation key” link in the License 
Information text to open the User Registration Form. 

3 In the User Registration Form, specify your e-mail address and your name. Entering the 
name of your company is optional. Specify if you want news from Parallels to be sent to you 
through e-mail.  We suggest allowing us to e-mail you in order for you to be informed of 
free software updates, new releases, and other Parallels-related news. 
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4 Finally, click the Register button to send this information to the Parallels Team. You will 
then have a free trial activation key sent immediately to the e-mail address you provided. 

If you’d prefer, you may register online at the Parallels website as well.  Click the Register 
On Site button at any time to proceed to the online registration. You will receive a free trial 
activation key through e-mail after completing the online form. 

If your trial key has expired, or you’re ready to start using Parallels Desktop with no time or 
feature restrictions, you’ll need a permanent activation key. Here’s how to get one: 

1 Click Help in the menu and select Activate Product. This opens the Activate Product screen. 

2 In the Activate Product screen, click the “purchase a permanent activation key” hyperlink in 
License Information text to open the Parallels Online Store and purchase a permanent 
activation key.  It’s just that simple.  

Activating Your Copy of Parallels Desktop 

To activate Parallels Desktop, follow these easy steps: 

1 Click Help in the Parallels Desktop menu and select Activate Product. 
2 In the Activate Product window, fill in the following fields: 

 In the Activation Key field type the key provided for you. When you fill in this field, the 
Activate button becomes active. 

 Specify your name and name of your company in the User Name and Company Name 
fields. Both of these fields are optional. 
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After entering your activation key, click the Activate button. If you have entered a valid 
activation key, the following confirmation message will be displayed: "Parallels 
Desktop has been activated successfully. Thank you!”  Now that your 
copy of Parallels Desktop is active, you can build, configure, and run virtual machines, 
congratulations!  

If You Activated with a Permanent Key 

After you have activated your copy of Parallels Desktop with a permanent activation key, you 
will be asked to register the next time you start Parallels Desktop. When you see the message 
shown below and click the Register button, the user registration online form will be opened in 
your Web browser. Please provide us with your contact information to receive notifications 
about our new updates and products. 
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Creating a Virtual Machine 

In the Parallels Desktop window click the  button. The OS Installation 
Assistant will help you build and configure virtual machine. The Assistant's Welcome screen 
appears. 
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Click the Next button. 
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Here we describe the typical OS installation which is an easy way to create a new virtual 
machine. (However, if you want to have a Windows XP or Vista virtual machine, there is an 
express installation, which is even easer way and which we recommend if you are new to 
virtualization. Please refer to the How to Build a Windows XP or Vista Virtual Machine topic). In 
the Select OS installation mode screen click the Typical OS installation option. Then click Next. 
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On the next screen, you specify what guest operating system you’d like to install on your virtual 
machine. Choose the operating system from the upper drop-down list (for example, Windows), 
and then choose the version from the lower one (Windows XP, Windows 95, or whatever). 
After specifying the guest OS, click Next. 
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In this step, you’re asked to name your virtual machine. If you plan to create several VMs 
running the same operating system, the name is needed for identification (“Windows XP for 
Games” and “Windows XP for Work”, for example). 

Also  specify where you want to store the files that make up your virtual machine. Unless you 
indicate otherwise, the assistant will name the VM after the guest OS you’ve specified and will 
store it in the Parallels folder. (You can change this default folder in Parallel Desktop’s 
Preferences dialog box. For more information, consult the full Parallels Desktop for Mac User 
Guide by choosing Help -> Contents.) Click Next. 
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This is the last screen of the OS Installation Assistant. After you click Finish, Parallels Desktop 
will create the virtual machine for you and then will start the installation. Do not forget to insert 
the installation disc before you click Finish. The installation of Windows XP is described in 
Installing Windows XP topic. 

However, if you don't want to install the guest OS right now or to install from a disc image or 
floppy image, clear the check box for the Start guest OS installation option. To learn how to start 
the installation refer to the Creating Virtual Machine -> Installing Guest OS section of the Parallels 
Desktop for Mac User Guide. 

When installing, you will have to capture the keyboard and mouse input in the virtual machine 
screen. See Capturing and Releasing the keyboard and the Mouse (page 23) to learn how to do 
this.  

After the guest OS installation is complete, install Parallels Tools if they are provided for your 
guest OS. Refer to the Parallels Tools (page 45) section. 
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Capturing the Keyboard and the Mouse 
in a Virtual Machine and Releasing Them 

When you power on a virtual machine, you get two computers running at once: your actual 
Mac, and the simulated PC that’s running inside it. But you have only one mouse and keyboard! 
How, then, is Parallels Desktop supposed to know when a certain mouse or keyboard activity is 
intended for Mac OS X, and when for the guest OS? 

The Automatic Handoff 

One obvious answer is: Whenever the cursor is inside the guest OS window, then it belongs to 
that OS. When the cursor moves out of the guest window, it belongs to Mac OS X once again. 

And indeed, that’s exactly how things work if you’ve installed Parallels Tools as described in 
the previous chapter. 

The Manual Handoff 

But Parallels Tools are not available for all guest operating systems; furthermore, some people 
may prefer to trigger the keyboard/mouse handoff manually. You can use any of three methods 
to make the virtual machine “capture” the keyboard and mouse: 

 Click anywhere inside the virtual machine window.  
 Select Capture Input in the VM menu. 
 Press Command+I on your keyboard. 

Once the guest OS captures your cursor, you can’t move it outside of the Parallels Desktop 
window until you release it. 

To release the keyboard and mouse to Mac OS X: 

 Press the keyboard shortcut for releasing your keyboard/mouse. The factory setting is 
Ctrl+Option(Alt), but you can change this key combo in Parallels Desktop -> 
Preferences -> Hot Keys. 

The keyboard and the mouse will be released immediately.  
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Installing Windows XP 

This topic describes an installation of Windows XP onto a virtual machine created by a 
typical installation  of OS Installation Assistant.  

Note. For successful installation you should have the full version of Windows XP, not any of 
the upgrade versions. 

If you are still on the last screen of OS Installation Assistant, with the Start Guest OS Installation 
option selected, then when you insert the installation disc and click the Finish button,  the 
assistant starts the installation of Windows XP in virtual machine.  

To start the installation in other cases you have to perform the following actions: 

1 Start Parallels Desktop. 

2 Open the virtual machine intended for Windows XP (for how to find and open the VM 
please refer to the Starting, Stopping, and Resetting a Virtual Machine  (page 47) topic). 

3 Insert the Windows XP installation disc or connect the .iso file of the installation disc to 
the virtual machine's CD/DVD-ROM drive. To connect the image file click the CD/DVD-
ROM icon on the status bar (at the bottom of the Parallels Desktop window) and select the 
Connect image file option from the pop-up menu/ then locate the image file. 

4 Power on the virtual machine. 

 



 Installing Windows XP 25 
 

With Windows XP you will proceed through the following set of screens: 

 Welcome to Setup screen is shown first. To capture your mouse and keyboard input inside 
the virtual machine click somewhere on the virtual machine monitor.  After this, press 
Enter on your keyboard. 

Note. You can return to Mac OS X at any time by pressing Ctrl+Alt  or 
Ctrl+Option(Alt) on your keyboard. 

 
 The license agreement is displayed on the screen. To scroll down press the Pagedown key. 

Then press F8 to agree. If you use MacBook or MacBook Pro press Fn+F8 instead. 

 

 



 Installing Windows XP 26 
 

 In the lower part of the following screen, the Setup displays the list of hard disks and 
partitions available in the virtual machine. You will have the only one item, the 
unpartitioned space. Press Enter to set up Windows XP on this object.  

 
 After this, you’ll have to choose how to format your system volume. It is best to format the 

Windows XP system disk using NTFS quick formatting method. So, select the type of file 
system and mode of formatting and press Enter. 
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 The virtual machine will restart automatically. The text stage of the installation is 
completed. During the next stage, dialog boxes will be used. Select your Regional and 
Language Options and proceed to entering license key. Type it and click Next. 
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 On the next several screens you will be asked to enter a computer name and administrator 
password, select your date and time zone, specify your network setting (we recommend to 
select typical ones).  

 Next you have to specify whether your computer will be a member of a domain. If you are 
creating the virtual machine for running it in corporate environment, ask your system 
administrator whether you should specify the domain. Otherwise, choose the first option, 
make your virtual machine a member of workgroup. 
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 After that, Setup adjusts the Display Settings for better image quality. 
 In the Help protect my PC screen indicate whether you want to turn on the Automatic 

Updating feature. We recommend to turn automatic updates on. 
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 As the next step, choose the way your computer will be connected to the Internet. Select 
Yes. 

 
 If you want to register with Microsoft specify this in the following screen. 
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 Setup prompts you to create user accounts for each person who will use this virtual 
machine. 

 
And this is all with the installation of Windows XP. But still there is one more important 
moment, installation of Parallels Tools. See Installing Parallels Tools section of this  guide.  
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Installing Windows Vista 

This topic describes an installation of Windows Vista onto a virtual machine created by a 
typical installation of OS Installation Assistant. 

If you are still on the last screen of OS Installation Assistant, with the Start Guest OS Installation 
option selected, then when you insert the installation disc and click the Finish button,  the 
assistant starts the installation of Windows XP in virtual machine.  

To start the installation in other cases (for example, if you have the .iso image of the 
installation disc) you have to perform the following actions: 

1 Start Parallels Desktop. 

2 Open the virtual machine intended for Windows Vista (for how to find and open the VM 
please refer to the Starting, Stopping, and Resetting a Virtual Machine  (page 47) topic). 

3 Insert the Windows Vista installation disc or connect the .iso file of the installation disc to 
the virtual machine's CD/DVD-ROM drive.  To connect the image file click the CD/DVD-
ROM icon on the status bar (at the bottom of the Parallels Desktop window) and select the 
Connect image file option from the pop-up menu/ then locate the image file. 

4 Power on the virtual machine. 
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With Windows Vista you will proceed through the following set of screens: 

 First, you have to specify your language and other regional preferences. To capture your 
mouse and keyboard input inside the virtual machine click somewhere inside the Windows 
Vista screen. 

Note. You can return to Mac OS X at any time by pressing Ctrl+Alt or 
Ctrl+Option(Alt) on your keyboard. 
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 In the next screen, you in general may proceed right to the installation itself by clicking 
Install now.  
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 Type your activation key in the following screen. You may skip this step now but don't 
forget to activate no later than 30 days after the installation.   
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 Read the vendor license terms, specify if you agree with them, then click Next. 
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 As long as you install the Vista onto a new virtual machine, the upgrade option is disabled. 
Click Custom (advanced) to proceed. 
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 In general, in this screen you may just proceed by clicking Next. In this case Vista will be 
installed onto the whole virtual hard disk. But if you like you may create other partitions for 
installation. 
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 When you click Next in the previous step, the installation itself starts. During it the virtual 
machine will be rebooted automatically several times. 
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 When the installation is in general performed, you have to set up your account. Type your 
user name and password. You may also specify a hint you will be told if you'll forgot the 
password in future.   
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 Next, you have to specify preferred protection option. As a rule, click Use recommended 
settings and then click Next. 
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 Make sure that your time and date settings are correct and click Next. 
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 Click Start in this screen to start Vista for the first time. 
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 Type you password specified at a previous step and press Enter to log in. 

 
And this is all with the installation of Windows Vista.  

To make your work with this virtual machine more comfortable, install Parallels Tools. See 
Installing Parallels Tools section of this guide.  
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Parallels Tools 

Although Parallels Desktop lets your guest OS access your Mac’s video card, network cards, 
and other hardware, it also simulates its own set of PC hardware (Key Terms and Technologies 
(page 5) topic).  

If you’ve installed Windows (except 3.1), Solaris, OS/2, or eComStation, Parallels provides 
special add-ons called Parallels Tools that improve some hardware components and add helpful 
extra features. For example, they let you: 

 use higher resolution and color depth for the guest OS monitor, 
 use the cursor in the guest OS without pressing a special key combination,  
 share the same clipboard between your guest OS and Mac OS X, so that you can exchange 

text and pictures, 
 improve network connections and sound quality.  

Note: In a Solaris guest OS, a network driver is required to support networking in a virtual 
machine (the driver is supplied with Parallels Tools). 

Parallels Tools can be easily installed manually after the guest OS installation is completed. 

Installing Parallels Tools in a Windows guest OS is described below. For other guest OSes, 
please refer to the Creating Virtual Machine->Installing Parallels Tools section of the Parallels 
Desktop for Mac User Guide, which is available through the Help->Contents menu in the menu 
bar. 

Installing Parallels Tools in Windows 

To install Parallels Tools in a Windows guest OS, do the following: 

1 First, boot your guest OS and log in. In order to install tools properly, do not begin the 
installation until the OS completes its startup and you are logged in. 

2 Select Install Parallels Tools in the Parallels Desktop VM menu.  

3 You see the following warning: "You can install the Parallels Tools 
only if the guest operating system is running and you are 
logged in. If you are not logged in now, select Cancel and 
run Parallels Tools installation later." If you are logged in, click OK.  

4 The Parallels Tools Setup wizard starts and greets you. Click Next to move to the Choose 
Destination Location screen. If you do not like the default directory, select another one using 
the Change button. Then click Next. 

5 On the Setup Type screen you should choose between the complete setup and a custom 
one. The complete setup installs all of the tools available for your guest OS. If you select 
custom setup, the Select Components screen prompts you to select the desired tools from the 
tools available for your guest OS. 
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6 Choose the program folder on the Select Program Folder screen, then the Check Setup 
Information screen displays the options selected. If they are correct, click Next to begin the 
installation. 

7 After the wizard copies the tools, the Installation Completed screen asks if you want to 
restart the computer now. In all Windows guest OSes, except 98 and NT, you must restart 
the virtual machine after this setup procedure. Click Finish, and your virtual machine will be 
restarted and ready for work with the tools installed. 

Note: In Windows 98 and Windows NT some drivers require additional steps to perform after 
this setup. Please refer to the Creating Virtual Machine->Installing Parallels Tools section of the 
Parallels Desktop for Mac User Guide, which is available through Help->Contents in the menu 
bar. 

Troubleshooting When Installing Tools 

Parallels Tools installation is invoked by the Windows AUTORUN feature for the CD/DVD-
ROM drive. It is enabled by default, however if you have disabled it manually, nothing happens 
after you select the Install Parallels Tools command. (In either case, the vmtools.iso CD 
image will be connected to the virtual machine CD-ROM drive, although it is not visible to the 
user). To solve this problem do one of the following: 

 Enable the AUTORUN function for the CD-ROM drive in your Windows guest OS. 
 Start the tools installation manually. 

Open the contents of the vmtools.iso in Windows Explorer, find PrlTools.exe file, 
and start it. 
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Starting, Stopping, and Resetting a 
Virtual Machine 

Once you have created a virtual machine and installed a guest OS, you can work in your virtual 
machine, customizing the installation and installing your favorite applications.  

Stopping a Virtual Machine 

You should shut down your virtual machine just as you would do this with a real PC. For 
example, if you’re running Windows, you click the Start button and then click Shut Down.  Only 
if you cannot stop the guest OS this way, you may use the Parallels Desktop controls: 

 Click the Power Off  button on the Parallels Desktop toolbar. 
 Choose VM -> Power Off from the menu. 

Resetting a Virtual Machine 

You should always restart a guest OS using its built-in Restart command. For example, in 
Windows, click Start, then Shut Down, then Restart.  

If for some reason that doesn’t work, only then you should use the Parallels Desktop controls: 

 Click the Reset button on the Parallels Desktop toolbar (or select VM->Reset ). 
 Select Send Ctrl+Option+Del in the VM menu (or make sure that the keyboard is captured 

inside a virtual machine and press Ctrl+Option(Alt)+Del ). 

Starting a Virtual Machine 

To start a virtual machine first, open Parallels Desktop. The last used virtual machine is opened 
by default. To open another virtual machine, select it from the list of recently used virtual 
machines as shown in the picture below: 

 

 



 Starting, Stopping, and Resetting a Virtual Machine 48 
 

Click the Power On  button on the Parallels Desktop toolbar (or choose VM -> Power On). 
The virtual machine switches on, its guest operating system starts loading...as you can see in the 
Parallels Desktop window..  

If you don't see the toolbar, click this   button in the upper right corner of the Parallels 
Desktop window to make the toolbar visible.  

Note that the virtual machine can only be powered on if your copy of Parallels Desktop has 
been activated with a permanent or trial activation key. If your copy is not activated, the "This 
copy of the Parallels Desktop is currently unregistered" warning 
will appear. In this case, you have to go back and activate your copy (see the Activating 
Parallels Desktop (page 14) chapter). 
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Running a Virtual Machine in Fullscreen 
Mode 

If it is more convenient for you by any reason, you can expand the guest OS screen so that it 
occupies your entire monitor screen, edge to edge.  

When a virtual machine is in fullscreen mode, Mac OS X and all of its programs are hidden. 
The Parallels Desktop menu, toolbar, and status bar will be hidden as well.  

If you want to run the virtual machine in fullscreen mode, make sure it’s already running. Then 
do one of these three things: 

 click the Fullscreen Mode  toolbar button,  
 select View->Fullscreen in the menu, 
 press Option(Alt)+Enter on your keyboard. 

To shrink the virtual machine screen to the usual (windowed) mode: 

 press Ctrl+Option(Alt) or Option(Alt)+Enter on your keyboard.  
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Accessing the Internet 

If you want to access the Internet in a virtual machine, start by making sure your Mac can itself 
get online.  

Then proceed like this:  

1 If your virtual machine is currently running, turn it off (click its Stop  button). You can 
change a VM's configuration only when it’s shut down.  

2 In the Parallels Desktop window, click Network Adapter in the Resources list to open the 
Configuration Editor screen which contains the Network Adapter Options. 

 
3 In Network Adapter Options, make sure that the Enabled and Connect cable at startup options 

are selected. In the Emulation group, select the Bridged Ethernet option and then choose the  
name of your network adapter in the list: 

 en0: Ethernet Adapter if you have a wired network connection, 

 en1: Airport/Wireless Adapter if you have a wireless connection, 

 or a specific adapter if you have a different one installed. 

4 Next, click OK on the Configuration Editor screen, then click the  button 
in the Parallels Desktop window (or choose File -> Save). 
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5 Now, start the virtual machine by clicking Power On on the toolbar. Capture the input 
devices in the guest OS screen (Capturing and Releasing Keyboard and Mouse in a Virtual 
Machine (page 23) chapter), if necessary. 

6 Configure network options in your guest operating system, just as you would on a new PC.  

Once you’re connected to the Internet, you can use your virtual machine to access email, surf 
the web, chat, and more! 
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Creating Shared Folders 

Having Parallels Tools installed lets you to transfer texts and small pictures between your Mac 
and virtual machine. To be able to transfer files you should set up shared folders. Shared folders 
are folders in your Mac file system that are visible to the guest OS also. In your Mac computer, 
shared folders appear as usual folders, while in the guest OS they are objects of the network 
neighborhood. 

Using shared folders is possible for the following guest OSes:  

 Windows 2000/XP/2003/Vista. 

Adding a Shared Folder 

1 Open the virtual machine configuration, click the  button to open the 
Configuration Editor. 

2 In the Configuration Editor, select the Shared Folders tab. Select the Enable shared folders 
option. 

 

3 In the Shared Folders tab, click  button to open the Shared Folder Properties dialog box. 

4 In the Shared Folder Properties dialog box: 

 specify a name for the folder which will appear in your guest OS in the Name field; 
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 specify a folder in your Mac OS X file system that will be shared in the Path field; 

 if you want to restrict writing to this folder from inside the guest OS, select the Read 
Only check box. You will be able to save files to this folder in the primary OS only; 

 make sure the Enabled check box is selected; 

 and click OK. 

 
5 Click OK in the Configuration Editor. 

6 Click  to save the virtual machine configuration. 

Note. To view the content of shared folders in a virtual machine you should have Parallels Tools 
installed. Refer to the Parallels Tools (page 45) chapter.  

Viewing Shared Folders 

To view the contents of the shared folders in the guest OS: 

1 Start the virtual machine. 

2 Open Windows Explorer. 
3 In the Explorer, select My Networks Places, then select Entire Network, and find the Parallels 

Shared Folders. 

4 Click the Parallels Shared Folders to view the list of shared folders available in your virtual 
machine. 

When working with a shared folder inside a virtual machine, keep in mind that the ability to 
save files into this folder depends on its Read Only setting. 
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